ACWGC Forums
http://www.wargame.ch/board/acwgc/

Help with sound
http://www.wargame.ch/board/acwgc/viewtopic.php?f=4&t=10976
Page 1 of 2

Author:  David Klebbe [ Sun Jun 10, 2007 3:36 am ]
Post subject:  Help with sound

Hope some one can help me with a strange phenomena.

When I play a game with the sound effects and background music on the music keeps repeating over and over in the beginning of a song. Like an old stuck record. Also, the melee sound effect does the same. It stays on and keeps repeating. I have to shut the game down and start over for the melee sound to stop. This does not happen with arty fire rifle fire sound effects.

I'm running windows xp professinal sp 2. When I go into the file itself and play the songs they play fine and they play fine in the getting started scenarios.

Hope you can help. This has me stimied!

Dave Klebbe Col, 1st Div., 2nd bgd., XIX corps, AOS

Author:  PAT [ Sun Jun 10, 2007 3:43 am ]
Post subject: 

My friend had the same problem. I don't know what he did. I'll e-mail him for info... See if he solved it or not.

Lt. Thompson
4/3/VIII AoS

Author:  Rich Walker [ Sun Jun 10, 2007 5:54 am ]
Post subject: 

I've had that problem from time to time. I just reboot and is usually clears up and plays normal.

Lt. Col. Richard Walker
I Corps
Army of the Mississippi
2nd Brigade, 3rd Division
"Defenders of Tennessee"

Author:  Atle Jenssen [ Sun Jun 10, 2007 6:06 am ]
Post subject: 

I have that problem with all my HPS/John Tiller games. I have to decrease the hardware acceleration of the sound card to get the sound & music to work properly. Give it a try - it might do the trick [:)]

MajGen Atle Jenssen
CO 2nd Division
XXth Corps
Army of the Cumberland
USA

Author:  Rich Walker [ Sun Jun 10, 2007 8:02 am ]
Post subject: 

How do you do that?

Still waiting for instructions

<blockquote id="quote"><font size="3" face="book antiqua" id="quote">quote:<hr height="1" noshade id="quote"><i>Originally posted by Atle Jenssen</i>
<br />I have that problem with all my HPS/John Tiller games. I have to decrease the hardware acceleration of the sound card to get the sound & music to work properly. Give it a try - it might do the trick [:)]

MajGen Atle Jenssen
CO 2nd Division
XXth Corps
Army of the Cumberland
USA

<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">

Lt. Col. Richard Walker
I Corps
Army of the Mississippi
2nd Brigade, 3rd Division
"Defenders of Tennessee"

Author:  David Klebbe [ Sun Jun 10, 2007 8:03 am ]
Post subject: 

Thanks to All, especially General Jenssen. Decreasing the hardware acceleration worked (so far).

Dave Klebbe Col, 1st Div., 2nd bgd., XIX corps, AOS

Author:  David Klebbe [ Sun Jun 10, 2007 8:05 am ]
Post subject: 

Thanks to All, especially General Jenssen. Decreasing the hardware acceleration worked (so far). I also sent to HPS. But I figured someone here would be faster and they were.

Dave Klebbe Col, 1st Div., 2nd bgd., XIX corps, AOS

Author:  Rich Walker [ Sun Jun 10, 2007 1:46 pm ]
Post subject: 

So how to you decrease acceleration?

Lt. Col. Richard Walker
I Corps
Army of the Mississippi
2nd Brigade, 3rd Division
"Defenders of Tennessee"

Author:  Robert [ Sun Jun 10, 2007 5:02 pm ]
Post subject: 

<font color="beige"><b>Mine started doing the same thing after I upgraded Norton (there may have been a windows update during that time also) a few weeks ago.

So how do you decrease acceleration???[?][?]</b></font id="beige">

<center><font color="blue"><b>Maj.Gen. R.A.Weir</b></font id="blue">
<font color="yellow">THE CALVERT LINE</font id="yellow">
Image
<b>First--III--AoA CSA</b></center>

Author:  Atle Jenssen [ Sun Jun 10, 2007 11:09 pm ]
Post subject: 

Hm... Maybe someone with an English version of XP could explain the procedure better than me, as my OS is in Norwegian [:D]

MajGen Atle Jenssen
CO 2nd Division
XXth Corps
Army of the Cumberland
USA

Author:  KWhitehead [ Mon Jun 11, 2007 5:04 am ]
Post subject: 

For the XP OS it is relatively simple.

Use the Run command from the Start menus.
If you don't have it inabled then run the old MSDos Command Prompt from the Accessories menu.

Type "dxdiag" and hit enter to execute.

This will open a multitab DirectX Diagnostic dialog window and start it analyzing your system.

It has tabs for all major features like Display and Sound. The one you want is Sound. When you select that tab you will see some sliders for setting the hardware exceleration. Change the setting and see if anything works better. A quick way to test is to move the slider all the way to the left turning off all acceleration and see if that affects the problem. If it fixes it then go back an start moving it back to the right until it fails to find your best setting.

If it still doesn't work it may not be your Sound acceleration. Go set it back the way it was.

I say it may not be the problem because on every computer I have ever run HPS games on I have seen it to some extent although never every time I play the game. Usually saving and stopping the game and restarting it stops the repeating.

If you are unlucky enough to have upgraded to Vista and someway gotten the new DirectX like me, you won't be able to set hardware acceleration. Vista drivers don't all support the feature.

LG. Kennon Whitehead
Chatham Grays
III Corps, AoM (CSA)

Author:  Rich Walker [ Mon Jun 11, 2007 6:29 am ]
Post subject: 

So if it is not a constant problem, don't worry about it? As I mentioned, if I restart, usually the problem goes away.

<blockquote id="quote"><font size="3" face="book antiqua" id="quote">quote:<hr height="1" noshade id="quote"><i>Originally posted by KWhitehead</i>
<br />For the XP OS it is relatively simple.

Use the Run command from the Start menus.
If you don't have it inabled then run the old MSDos Command Prompt from the Accessories menu.

Type "dxdiag" and hit enter to execute.

This will open a multitab DirectX Diagnostic dialog window and start it analyzing your system.

It has tabs for all major features like Display and Sound. The one you want is Sound. When you select that tab you will see some sliders for setting the hardware exceleration. Change the setting and see if anything works better. A quick way to test is to move the slider all the way to the left turning off all acceleration and see if that affects the problem. If it fixes it then go back an start moving it back to the right until it fails to find your best setting.

If it still doesn't work it may not be your Sound acceleration. Go set it back the way it was.

I say it may not be the problem because on every computer I have ever run HPS games on I have seen it to some extent although never every time I play the game. Usually saving and stopping the game and restarting it stops the repeating.

If you are unlucky enough to have upgraded to Vista and someway gotten the new DirectX like me, you won't be able to set hardware acceleration. Vista drivers don't all support the feature.

LG. Kennon Whitehead
Chatham Grays
III Corps, AoM (CSA)
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">

Lt. Col. Richard Walker
I Corps
Army of the Mississippi
2nd Brigade, 3rd Division
"Defenders of Tennessee"

Author:  KWhitehead [ Mon Jun 11, 2007 8:54 am ]
Post subject: 

If its only ocassional I wouldn't try to fix it. I believe its a bug in the HPS handling playing wave sounds since I have never seen the problem in any other game.

LG. Kennon Whitehead
Chatham Grays
III Corps, AoM (CSA)

Author:  Michael Smith [ Mon Jun 11, 2007 10:43 am ]
Post subject: 

For those using XP you can also adjust acceleration without a command prompt. For those who may prefer a gui interface than a command line. To do this click on START -----> CONTROL PANEL ------> Sound (Either in classic view or the default view its essentially the same though perhaps worded as sounds, speech and audio devices, then click adjust volume) and the sound and audio properties box will appear. The first tab activated by default is the VOLUME tab and down in the bottom right of this properties box you'll see a button titled ADVANCED. This will open another box wherein the default tab is set for SPEAKERS. The tab to the right, and the only other tab in this box, will be labeled PERFORMANCE click this tab and you'll now see a sliding control to adjust hardware acceleration. You may need to adjust this a few times to get the best setting for your system.

Kennon's suggestion works just as well and may be easier for many. I just thought some may be more comfortable not using command line structure. Hope its helpful.....



Maj.Gen. Mike Smith
3rd Bde, 1st Div
II Corps
Army of Georgia
[url="http://convolutedmuse.com"]ConvolutedMuse[/url]

Author:  Robert [ Mon Jun 11, 2007 3:55 pm ]
Post subject: 

<font color="beige"><b>Thanks Mike....works like a charm so far</b></font id="beige">[:D]

<center><font color="blue"><b>Maj.Gen. R.A.Weir</b></font id="blue">
<font color="yellow">THE CALVERT LINE</font id="yellow">
Image
<b>First--III--AoA CSA</b></center>

Page 1 of 2 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/